EIGRP Named-Mode

Starting with version 15, Cisco has announced major changes to its IOS and one of them is the way of configuring the EIGRP. This method is called EIGRP named-Mode, in which you are supposed to configure EIGRP with given name, rather than an AS number in global configuration mode. Actually there is not huge difference between the configuration of the two and I think you must not have any difficulties if you are used to work with the older version. So I’m going to show you a simple scenario in which I will go through the new method of configuration. Suppose we have a simple topology as shown above.
Routers R4 and R6 have two different VRFs, named A and B. VRF A runs between R4, R5 and R6 and VRF B runs over the direct links between R4 and R4.

R4(config)#do sh ip vrf
  Name                           Default RD       Interfaces
  A                                1:1                Lo0
                                                        Fa0/0
  B                                2:2                Lo1
                                                        Fa0/1
R6(config)#do sh ip vrf
  Name                           Default RD       Interfaces
  A                                1:1                Lo0
                                                        Fa0/1
  B                                2:2                Lo1
                                                        Fa0/0

Our addresses are as follow:

R4(config)#do sh ip inter br 
Interface               IP-Address      OK? Method Status                Protocol
FastEthernet0/0      45.45.45.4      YES manual up                    up      
FastEthernet0/1      46.46.46.4      YES manual up                    up      
Loopback0              4.4.4.4          YES manual up                    up      
Loopback1              4.4.4.5          YES manual up                    up      
R6(config)#do sh ip inter br 
Interface               IP-Address      OK? Method Status                Protocol
FastEthernet0/0      46.46.46.6      YES manual up                    up      
FastEthernet0/1      56.56.56.6      YES manual up                    up      
Loopback0              6.6.6.6          YES manual up                    up      
Loopback1              6.6.6.7          YES manual up                    up      
R6(config)#

Now let’s start our configuration of EIGRP named-mode one-by-one; first we start with R4:

router eigrp test
 !
 address-family ipv4 unicast vrf A autonomous-system 1
  !
  topology base
  exit-af-topology
  network 4.4.4.4 0.0.0.0
  network 45.0.0.0
 exit-address-family
 !
 address-family ipv4 unicast vrf B autonomous-system 2
  !
  topology base
  exit-af-topology
  network 4.4.4.5 0.0.0.0
  network 46.0.0.0
 exit-address-family

As you see above, I’ve used a “name” instead of the AS number in “router eigrp” command. This name is unique on a local system and it can be different on neighbors. Then you should run “address-family” command to enter AF configuration mode. This command differs from what you are used to enter in ways, it has “autonomous-system” parameter at the end. This parameter determines the AS number, as you have seen before in old fashion. While in AF configuration mode, you can enter many known commands, like “network, timers, neighbor, etc”.

R6(config-router-af)#?
Address Family configuration commands:
  af-interface         Enter Address Family interface configuration
  default              Set a command to its defaults
  eigrp                EIGRP Address Family specific commands
  exit-address-family  Exit Address Family configuration mode
  help                 Description of the interactive help system
  maximum-prefix       Maximum number of prefixes acceptable in aggregate
  metric               Modify metrics and parameters for address advertisement
  neighbor             Specify an IPv4 neighbor router
  network              Enable routing on an IP network
  no                   Negate a command or set its defaults
  shutdown             Shutdown address family
  timers               Adjust peering based timers
  topology             Topology configuration mode

For simplicity, I didn’t change any defaults of EIGRP. I activated EIGRP test (AS 1) on loopback 0 and f0/0 and EIGRP test (AS 2) on loopback 1 and f0/1. The same process is needed on R6 too:

router eigrp test
 !
 address-family ipv4 unicast vrf A autonomous-system 1
!
  topology base
  exit-af-topology
  network 6.6.6.6 0.0.0.0
  network 56.0.0.0
 exit-address-family
 !
 address-family ipv4 unicast vrf B autonomous-system 2
  !
  topology base
  exit-af-topology
  network 6.6.6.7 0.0.0.0
  network 46.0.0.0
 exit-address-family

Despite different versions of EIGGRP are running and configured between two devices, they will establish EIGRP neighborship if the AS numbers and K-values are same between the two, as before. For testing purpose, I configured EIGRP in old format on R5:

router eigrp 1
 network 5.0.0.0
 network 45.0.0.0
 network 56.0.0.0

And test the neighbors for EIGRP:

R4(config)#do sh ip eigrp vrf A neigh
EIGRP-IPv4 VR(test) Address-Family Neighbors for AS(1)
           VRF(A)
H   Address                 Interface              Hold Uptime   SRTT 
                                                          (sec)         (ms) 
0   45.45.45.5              Fa0/0                    10 01:12:33   90
R4(config)#do sh ip route  vrf A
Routing Table: A
Gateway of last resort is not set

      4.0.0.0/32 is subnetted, 1 subnets
C        4.4.4.4 is directly connected, Loopback0
      5.0.0.0/32 is subnetted, 1 subnets
D        5.5.5.5 [90/2662400] via 45.45.45.5, 01:12:53, FastEthernet0/0
      6.0.0.0/16 is subnetted, 1 subnets
D        6.6.0.0 [90/154240] via 45.45.45.5, 01:00:39, FastEthernet0/0
      45.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        45.45.45.0/24 is directly connected, FastEthernet0/0
L        45.45.45.4/32 is directly connected, FastEthernet0/0
      56.0.0.0/24 is subnetted, 1 subnets
D        56.56.56.0 [90/153600] via 45.45.45.5, 01:12:37, FastEthernet0/0
R4(config)#dir vrf B
Routing Table: B
Gateway of last resort is not set

      4.0.0.0/32 is subnetted, 1 subnets
C        4.4.4.5 is directly connected, Loopback1
      6.0.0.0/32 is subnetted, 1 subnets
D        6.6.6.7 [90/103040] via 46.46.46.6, 01:11:46, FastEthernet0/1
      46.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        46.46.46.0/24 is directly connected, FastEthernet0/1
L        46.46.46.4/32 is directly connected, FastEthernet0/1

Test the reachability for VRF A:

R4(config)#do ping vrf A 6.6.6.6
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/62/84 ms

And for VRF B:

R4(config)#do ping vrf B 6.6.6.7
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 6.6.6.7, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/45/60 ms

Auto-summarization is off by default and you will need to do it manually if there is a need. At the second phase I want R6 and R6 authenticate each other. The way of doing that on R5 is simple:

R5(config)#do sh run
key chain TCH
 key 1    
   key-string cisco
!         
interface FastEthernet0/1
 ip address 56.56.56.5 255.255.255.0
 ip authentication mode eigrp 1 md5
 ip authentication key-chain eigrp 1 TCH

But it is different on R6 that uses EIGRP named-mode. In new format, all of the configuration that was issued in interface configuration mode, should be run in “af-interface” configuration modem like authentication, summarization, etc.

R6(config)#do sh run
key chain TCH
 key 1
   key-string cisco
!
address-family ipv4 unicast vrf A autonomous-system 1
  !
  af-interface Loopback0
   passive-interface
  exit-af-interface
  !
  af-interface FastEthernet0/1
   summary-address 6.6.0.0 255.255.0.0
   authentication mode md5
   authentication key-chain TCH
  exit-af-interface

I configured authentication and summarization on R6, so R6 and R5 will authenticate each other with the help of “key chain TCH” and R6 will summarize its loopback into 6.6.0.0/16 while sending updates to R5 through its f0/1 interface. Also I put loopback0 of R6 in passive-mode, so no updates and hello will be advertised on it anymore.

R5(config)#do sh ip route  
Gateway of last resort is not set

      4.0.0.0/32 is subnetted, 1 subnets
D        4.4.4.4 [90/28160] via 45.45.45.4, 01:32:44, FastEthernet0/0
      5.0.0.0/32 is subnetted, 1 subnets
C        5.5.5.5 is directly connected, Loopback0
      6.0.0.0/16 is subnetted, 1 subnets
D        6.6.0.0 [90/28160] via 56.56.56.6, 01:20:30, FastEthernet0/1
      45.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        45.45.45.0/24 is directly connected, FastEthernet0/0
L        45.45.45.5/32 is directly connected, FastEthernet0/0
      56.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        56.56.56.0/24 is directly connected, FastEthernet0/1
L        56.56.56.5/32 is directly connected, FastEthernet0/1

You see that 6.6.0.0/16 is in R5’s routing table instead of actual route, 6.6.6.6/32. And we finished now. You can play with new EIGRP and find more for sure by your own and I will publish even more ASAP.

This article has 2 comments

  1. Yunas Reply

    I suppose u used GNS3 for run this lab, am I right?
    Have you used 7200 model in your lab? What IOS version do you use for it?

    • tim Reply

      Hi; yes I used 7200 series to setup EIGRP named-mode. the version I used was 15.2(4)s.

Leave a Reply to Yunas Cancel reply

Your email address will not be published. Required fields are marked *

* Copy This Password *

* Type Or Paste Password Here *

2,050 Spam Comments Blocked so far by Spam Free Wordpress

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>